This topic contains 7 replies, has 2 voices, and was last updated by  Ellen 7 months, 2 weeks ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #19127

    Slidebird
    Participant

    Hi

    We use 8 different languaages and are using yout build in switcher like in the screenshot here http://prntscr.com/hhv2wv

    but on mobile the witcher doesnt appear at all, why? is it possible to show the switcher in the header on mobile?
    http://prntscr.com/hhv4v9

    thanks

    #19128

    Slidebird
    Participant

    ah ok i found it… you set the value of the .lang-sel class on display: none… so i changed it to

    @media only screen and (max-width: 1100px)
    {
    #header-container:not(.small):not(.logo-position-right) #header .header-wrap > .row:last-child .columns.header-main-panel .lang-sel {
    display: inline-block;
    }
    }

    but no i see why you did it… its a list which onyl works with hoover…

    is it possible to set the lang-sel to only open the list on klick and then a second click for the language?

    thanks

    #19129

    Slidebird
    Participant

    or also possible to just make the list appear on click on dekstop as well?

    • This reply was modified 7 months, 2 weeks ago by  Slidebird.
    • This reply was modified 7 months, 2 weeks ago by  Slidebird.
    #19135

    Ellen
    Participant

    Hello Slidebird!

    Please try following CSS code

    @media only screen and (max-width: 1100px){
    #header-container:not(.small):not(.logo-position-right) #header .header-wrap > .row:last-child .columns.header-main-panel .lang-sel {
    display: block;
    margin-left: 0;
    }}
    

    You can add the code to Theme Options > General Options > Custom CSS/JS > Custom CSS.

    Best regards,
    DFD Support Team

    #19139

    Slidebird
    Participant

    i already tried this…doesnt work… as soon i touch the lang switcher it changes the languege to fthe first visible language before it opens the list

    • This reply was modified 7 months, 2 weeks ago by  Slidebird.
    #19142

    Slidebird
    Participant

    i guess it would work with an empty js like this onclick=”void(0)”

    but i dont think its a good way to do this but maybe a workaround for now if it works… but i cant find the div container for the lang-sel anyway… thought it would be in the header.php but nope

    #19143

    Slidebird
    Participant

    ok found the block-lang_sel.php but my idea did not work… :-(

    #19144

    Ellen
    Participant

    Hello Slidebird!

    Could you please contact us via [email protected] email and we’ll find the solution for you.
    Please do not forget to email us the WP access details and link to the site.

    Regards,
    DFD Support Team

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.